likes
comments
collection
share

nvm解决多项目node-sass与node版本不对应问题

作者站长头像
站长
· 阅读数 23

node-sass编译语言比较特殊,需要下载对应版本的编译器才能编译,使用node-sass与node版本对应,会导致启动项目报错,类似“提示node-gyp -v”。解决方案要么统一node-sass与node版本,但是我觉得nvm管理node版本比较好,这样不用去修改所有的项目node-sass或者node版本,分开管理。

  1. 首先安装nvm根据教程安装nvm(最好是看清楚是安装在那个文件夹下面,方便后面解决问题)nvm解决多项目node-sass与node版本不对应问题

说明:文档说需要卸载之前的node,但是我发现不需要,安装nvm过程中有询问是否需要nvm管理目前电脑现有的node版本,如下图:nvm解决多项目node-sass与node版本不对应问题

  1. 安装完成之后直接,打开CMD,根据nvm文档,输入命令安装所需要的node版本,nvm install [version] 我安装了16.14.2 14.4.0,看下图nvm解决多项目node-sass与node版本不对应问题

其他:这是安装比较顺利,npm都有。其实还遇到了另外一种情况,检查node -v正常,但是npm -v的是时候报错,提示:“ 'npm' 不是内部或外部命令,也不是可运行的程序”,查询了之后发现都是建议检查电脑配置环境变量,我后来添加了发现还是不行。查询之后发现是安装好的nvm目录里面指定的node文件夹里面不存在npm 与 npm.cmd文件。nvm解决多项目node-sass与node版本不对应问题后来看到这篇NVM安装node.js后没有npm解决了nvm解决多项目node-sass与node版本不对应问题

以上是我遇到问题之后的解决办法。整理小记。